Update dependencies
[dane-monitoring-plugins.git] / README.md
1 # Scope
2
3 The set of monitoring plugins in this repository is intended to serve
4 as icinga / nagios / .. checks for DANE enabled network services. The
5 central functionality therefore is checking whether the services
6 conforms with the DANE records. However, all service plugins are also
7 supposed to work as *the* plugin for each service and should be able
8 to monitor all relevant properties.
9
10 # Getting the Code
11
12 The main repository is located at [git.siccegge.de][1] but mirrors can
13 be found on both [GitLab][2] and [GitHub][3]. Pull request will be
14 processed by mail as well as on both platforms.
15
16 [1]: https://git.siccegge.de/?p=dane-monitoring-plugins.git
17 [2]: https://gitlab.com/siccegge/dane-monitoring-plugins
18 [3]: https://github.com/siccegge/dane-monitoring-plugins
19
20 # Dependencies
21
22 The plugins need pyasn1, pyasn1-modules and pyunbound as well as
23 python3. The check_dnssec module needs additionally the python ldns
24 module. Unfortunately the unbound package in Debian only provides
25 python2 modules currently. Building pyunbound from source works fine
26 however.
27
28 # License
29
30 Unfortunately the problems at hand tend to result in a dependency on
31 OpenSSL which makes plain GPL inviable. Until a proper decision is
32 made you can assume GPLv3 with OpenSSL exception