Update requirements as verified by sbuild package build
[frida/doc.git] / source / installing.rst
1 Installation
2 ------------
3
4 These instructions have all been tested on Debian jessie systems
5 only. Patches and hints for other distributions are welcome!
6
7 Build requirements
8 ==================
9
10 Frida requires the following packages for building
11
12 * cmake
13 * pkg-config
14 * LLVM 3.5
15 * Qt5 (5.2 or newer preferred)
16 * QuaZIP
17 * log4cxx
18 * guile-2.0
19 * google-mock
20 * swig
21 * Boost (signals2)
22 * libedit (through LLVM)
23
24 On a debian (jessie) system this works with the following command:
25
26 .. code-block:: bash
27
28 apt install cmake pkg-config llvm-3.5-dev libquazip-qt5-dev liblog4cxx10-dev qtbase5-dev guile-2.0-dev google-mock swig libboost-dev libedit-dev
29
30
31 Note that version 3.5 of LLVM is required.
32
33 Building
34 ========
35
36 I would recommend an out-of tree build which works as follows
37
38 .. code-block:: bash
39
40 mkdir build
41 cd build
42 cmake ..
43 make -j
44
45 Which should generate you a frida binary. If you don't want to install
46 gmoch/gtest you need to remove the stanzas from CMakeList and not run
47 the tests.