Update requirements as verified by sbuild package build
authorChristoph Egger <christoph@christoph-egger.org>
Thu, 19 Mar 2015 00:40:44 +0000 (01:40 +0100)
committerChristoph Egger <christoph@christoph-egger.org>
Thu, 19 Mar 2015 00:40:44 +0000 (01:40 +0100)
source/installing.rst

index bca5a798565b6431e5247130e8b2e72761b12333..e1fb8f03607401b18e8d68225effdf158183ec73 100644 (file)
@@ -9,20 +9,24 @@ Build requirements
 
 Frida requires the following packages for building
 
+* cmake
+* pkg-config
 * LLVM 3.5
-* Qt >= 5.1
-* guile-2.0
+* Qt5 (5.2 or newer preferred)
+* QuaZIP
 * log4cxx
-* quazip
-* gtest
-* gmock
-* cmake
+* guile-2.0
+* google-mock
+* swig
+* Boost (signals2)
+* libedit (through LLVM)
 
 On a debian (jessie) system this works with the following command:
 
 .. code-block:: bash
 
-   apt-get install libquazip-qt5-dev liblog4cxx10-dev qtbase5-dev guile-2.0-dev google-mock cmake g++ llvm-3.5-dev
+   apt install cmake pkg-config llvm-3.5-dev libquazip-qt5-dev liblog4cxx10-dev qtbase5-dev guile-2.0-dev google-mock swig libboost-dev libedit-dev
+
 
 Note that version 3.5 of LLVM is required.